筋肉女子のプログラミング記録

プログラミング初心者三十路越えアスリート系女がフリーランスプログラマーを目指すブログ

Original Error: You must have ImageMagick installedの解決

スポンサーリンク

f:id:simpledancer:20190407081054j:plain

もうちょっと見た目の修正を、、、と思いデザインを直したり、ちゃんと画像がアップrされるかと確認していたら、エラーがでた。

 

 

ローカルでブログがアップされるか確認しようとしてみると

アップできない!本番環境では動いている。なぜ?

Original Error: You must have ImageMagick or GraphicsMagick installed

1 error prohibited this form_field_value from being saved:
Image Failed to manipulate with MiniMagick, maybe it is not an image? Original Error: You must have ImageMagick or GraphicsMagick installed

結果的にinstallしたら正常にアップロードできたわけなのですが、

sudo apt-get install imagemagick

git push heroku masterした後のherokuからは特にワークスペースの変更もしてないのに

ローカルでだけアップロードできないのはなぜなのだろうか??

ここは私の思い違いのだけなのかもしれないけど。。。

参考

stackoverflow.com

qiita.com